服务器中多个wordpress启用Redis Object Cache时,默认redis端口6379修改后,不用改代码自动升级的方法

发布时间:2021-08-04 19:58 最后更新:2023-02-20 16:25 浏览量:共 22 次浏览

服务器中多个wordpress启用Redis Object Cache时,默认redis端口6379修改后,不用改代码自动升级的方法

修改根目录下的wp-config.php,来实现多站点,自定义端口的问题。

插入的位置为:
define( 'WP_DEBUG', false );

【配置文件插入到此,否则放到最后,会失效。】

/* That's all, stop editing! Happy publishing. */
/* 好了!请不要再继续编辑。请保存本文件。使用愉快! */

【示范如下】:

define('WP_DEBUG', false);

/** REDIS相关配置,一定要放在 define( 'WP_DEBUG', false ); 之后,
* That's all, stop editing! Happy publishing. / 之前
* 否则,直接放在最后,是不生效的。此处错误切记!
* 然后,REDIS每次升级,不用修改端口了。很好用!
* @link https://github.com/rhubarbgroup/redis-cache/wiki
* define( 'WP_REDIS_PREFIX', 'it.hsx.ltd' ); 域名不能加HTTP,解决同一服务器中支持多个WP站点
* define( 'WP_REDIS_PORT', 8888 ); 端口默认的6379改成自定义的,统一在这修改,后面升级不用改代码
* define( 'WP_REDIS_DATABASE', 4 ); 指定REDIS数据库的序号,按此方法,服务器中最高16个WP站 */
define( 'WP_REDIS_PREFIX', 'it.hsx.ltd' );
define( 'WP_REDIS_PORT', 8888 );
define( 'WP_REDIS_DATABASE', 4 );

/* That's all, stop editing! Happy publishing. */ 【英文】
/* 好了!请不要再继续编辑。请保存本文件。使用愉快! */【中文】

2021-07-19咨询官方后,得解。

 

相关文章

调所有前端VUE,标题四个字,超过自动调行,字和框竖向自动居中
【Simply Static生成静态失败】宝塔防火墙拦截了服务器本机访问自身域名 / IP 的环回请求
zhong zhuan
宝塔面板中如何修改网站顺序
Ubuntun和debian 系统升级
【教程】Simply Static配置详情